Gavin

修改wordpress代码高亮插件CodeColorer使之兼容PHP7

VPS升级为PHP7后,发现以前的文章各种错误提示,惨不忍睹,目标直至代码高亮插件CodeColorer 查了下原因,问题出在preg_replace这个函数的/e修饰符上,参考官方文档 更新日志 版本 说明 5.5.0 /e 修饰符已经被弃用了。使用 preg_replace_callback() 代替。参见文档中 PREG_REPLACE_EVAL 关于安全风险的更多信息。 解决方案自然是修改 […]